CI builds failing for ppc64, ppc64le and s390x

# Eike Rathke (4 days ago)

Currently the CI builds for ppc64, pc64le and s390x are failing with the attached error message, taken from ppc64 but the same for all three platforms. It started on May-22 with the indicated changes. I assume there's some alignment/packing difference for these platforms, didn't dig into it yet; does that ring a bell with someone?

Eike

Contact us to advertise here
# Michael Catanzaro (4 days ago)

Did your builds for ARM succeed? We're having a similar (though completely different) packing problem there:

bugs.webkit.org/show_bug.cgi?id=198274

# Eike Rathke (4 days ago)

On Monday, 2019-06-03 10:25:20 -0500, Michael Catanzaro wrote:

Did your builds for ARM succeed?

Yes, aarch64 builds.

Eike

# Saam Barati (4 days ago)

In JavaScriptCore, we make changes all the time that could break builds along these lines. For this, it sounds like someone is doing a bad bitwise_cast, and it should be trivial to fix. My guess based on the variable names is it’s one of Keith’s RegExp changes.

# Michael Catanzaro (3 days ago)
# Eike Rathke (10 hours ago)

On Monday, 2019-06-03 17:38:57 +0200, Eike Rathke wrote:

On Monday, 2019-06-03 10:25:20 -0500, Michael Catanzaro wrote:

Did your builds for ARM succeed?

Yes, aarch64 builds.

FWIW, 2.25.1 fails the same for armv7hl, which isn't covered by our CI. koji.fedoraproject.org/koji/taskinfo?taskID=35343619

Eike

Want more features?

Request early access to our private beta of readable email premium.