[CMake] Bump cmake_minimum_required version to 3.10

# Fujii Hironori (5 days ago)

I'm going to bump cmake_minimum_required version to 3.10 for shining new features.

Bug 199181 โ€“ [CMake] Bump cmake_minimum_required version to 3.10 bugs.webkit.org/show_bug.cgi?id=199181

GTK and WPE's EWS and BuildBot bots maintainers, could you please update your CMake on your bots?

If you are using CMake Visual Studio generator, you need CMake 3.12 or newer to avoid an unnecessary recompilation issue.

AppleWin port seems still using old Visual Studio 2017. If it will switch to Visual Studio 2019 for better C++17 support, Visual Studio 2019 needs CMake 3.14 or newer. cmake.org/cmake/help/v3.14/release/3.14.html#generators

Happy WebKit 18th webkit.org/blog/6888/celebrating-15-years-of-webkitbirthday donmelton.com/2017/06/25/sweet-sixteen-for-safari-and-webkit๐ŸŽ‚

Contact us to advertise here
# Fujii Hironori (2 days ago)

jsc-i368 EWS is still failing. Who is igalia-jsc-i386-ews bot maintainer?

On Mon, Jun 24, 2019 at 8:21 PM Fujii Hironori <fujii.hironori at gmail.com>

wrote:

# Xan (2 days ago)

Sorry about that. We'll take care of it ASAP.

# Adrian Perez de Castro (2 days ago)

Hello,

On Thu, 27 Jun 2019 08:36:22 +0200, Xan <xan.lopez at gmail.com> wrote:

Sorry about that. We'll take care of it ASAP.

Cheers, Xan

On Thu, Jun 27, 2019, 06:23 Fujii Hironori <fujii.hironori at gmail.com> wrote:

jsc-i368 EWS is still failing. Who is igalia-jsc-i386-ews bot maintainer?

Done, this EWS has now CMake 3.13 as well (from the Debian Stretch backports repository). I managed to miss this bot yesterday โ€” sorry.

Please do let me know if you find any other issues with our bots :)

Cheers, โ€”Adriรกn

On Mon, Jun 24, 2019 at 8:21 PM Fujii Hironori <fujii.hironori at gmail.com> wrote:

Hi,

I'm going to bump cmake_minimum_required version to 3.10 for shining new features.

Bug 199181 โ€“ [CMake] Bump cmake_minimum_required version to 3.10 bugs.webkit.org/show_bug.cgi?id=199181

GTK and WPE's EWS and BuildBot bots maintainers, could you please update your CMake on your bots?

If you are using CMake Visual Studio generator, you need CMake 3.12 or newer to avoid an unnecessary recompilation issue.

AppleWin port seems still using old Visual Studio 2017. If it will switch to Visual Studio 2019 for better C++17 support, Visual Studio 2019 needs CMake 3.14 or newer. cmake.org/cmake/help/v3.14/release/3.14.html#generators

Happy WebKit 18th webkit.org/blog/6888/celebrating-15-years-of-webkitbirthday donmelton.com/2017/06/25/sweet-sixteen-for-safari-and-webkit๐ŸŽ‚

-- Fujii


webkit-dev mailing list webkit-dev at lists.webkit.org lists.webkit.org/mailman/listinfo/webkit-dev

Non-text part: text/html

# Brent Fulgham (2 days ago)

Apple is in the process of bringing up VS2019 now. I would be in favor of moving the minimum to 3.14 so we can safely support VS2019 compiles.

# Michael Catanzaro (2 days ago)

On Thu, Jun 27, 2019 at 11:20 AM, Brent Fulgham <bfulgham at apple.com>

wrote:

Apple is in the process of bringing up VS2019 now. I would be in favor of moving the minimum to 3.14 so we can safely support VS2019 compiles.

The 3.14 target is too aggressive for WPE/GTK, unfortunately. You could use a different cmake_minimum_required for Windows only, of course.

# Konstantin Tokarev (2 days ago)

27.06.2019, 20:19, "Michael Catanzaro" <mcatanzaro at igalia.com>:

On Thu, Jun 27, 2019 at 11:20 AM, Brent Fulgham <bfulgham at apple.com> wrote:

Apple is in the process of bringing up VS2019 now. I would be in favor of moving the minimum to 3.14 so we can safely support VS2019 compiles.

The 3.14 target is too aggressive for WPE/GTK, unfortunately. You could use a different cmake_minimum_required for Windows only, of course.

Note that you don't have to raise cmake_minimum_required to use newer CMake in your builds.

# Fujii Hironori (2 days ago)

Good news! Use CMake 3.14.5 to avoid another incremental build issue.

Bug 198850 โ€“ [CMake][Win] WTF_CopyHeaders copies files everytime in incremental builds if Visual Studio generator is used bugs.webkit.org/show_bug.cgi?id=198850

Want more features?

Request early access to our private beta of readable email premium.