Rename Bugzilla's "WebKit2" component to "WebKit Process Model"

# Lucas Forschler (6 days ago)

Hello all,

I am modernizing/cleaning up our Bugzilla component names. The first one I’d to rename is the WebKit2 component. I would like to rename this component to “WebKit Process Model”.

Are there any objections or concerns with this rename?

Thanks, Lucas

Contact us to advertise here
# Ryosuke Niwa (6 days ago)

Hm... I think WebKit2 component is currently used to implement both WebKit Process Model as well as WKWebView / WebKit2 API.

So we probably need to split it into multiple components, one of which is WebKit Process Model.

  • R. Niwa On Fri, Feb 1, 2019 at 10:27 AM Lucas Forschler <lforschler at apple.com>

wrote:

# Lucas Forschler (a day ago)

Thanks Ryosuke,

I’d be in favor of adding a Bugzilla component “WebKit Process Model” I believe Simon has also asked for a WKWebView component. (WKWebView viewport/tiling/animated resize issues)

Would the two of these components be sufficient to replace WebKit2?

Lucas

# Maciej Stachowiak (a day ago)

On Feb 6, 2019, at 9:48 AM, Lucas Forschler <lforschler at apple.com> wrote:

Thanks Ryosuke,

I’d be in favor of adding a Bugzilla component “WebKit Process Model” I believe Simon has also asked for a WKWebView component. (WKWebView viewport/tiling/animated resize issues)

Would the two of these components be sufficient to replace WebKit2?

I would suggest we rename “WebKit API” to “Legacy WebKit API” and call the new component “WebKit API” rather than “WKWebView”.

Want more features?

Request early access to our private beta of readable email premium.