Terminology: Could we change 'roll out' to 'roll back'?

# Kirsling, Ross (13 hours ago)

Greetings WebKittens,

Late on Friday seems like a good time for a terminological debate (😂), so I’d like to propose we revisit one of the strangest items of WebKit-specific terminology: the phrase ‘roll out’.

In our industry, the typical meaning of the phrase ‘roll out’ is, of course, ‘deploy’ or ‘launch’; this corresponds with the colloquial usage of ‘roll out’ to mean ‘depart (for a destination)’. In WebKit, we use ‘roll out’ to mean the exact opposite, ‘revert’ or ‘roll back’.

In terms of metaphors: The typical meaning of ‘roll out’ is synonymous with ‘roll forward’, hence the opposite being ‘roll back’. The way that I came to explain to myself and others what WebKit means by ‘roll out’ is that it’s movement along the other axis. There is a tree (SVN trunk) which is built up from disc-shaped slices (revisions), and these slices are rolled sideways in and out of the tree. Needless to say, this is not obvious to a newcomer, and it’s not even accurate to how SVN works—rollouts don’t remove an old revision, they add a new revision to perform the revert!

This term is confusing enough for native English speakers outside our community, let alone non-natives (since phrasal verbs are notoriously tricky as it is). Having heard complaints about this from people in both of these groups within the last few weeks, I hereby propose that we start using ‘roll back’ instead. Given the string similarity between the two, I hope that this will be a relatively easy change to enact, if folks are onboard with it.

Thanks for your consideration!

Ross

Contact us to advertise here
# Ryosuke Niwa (13 hours ago)

On Fri, Mar 6, 2020 at 6:15 PM Kirsling, Ross <Ross.Kirsling at sony.com> wrote: >

Late on Friday seems like a good time for a terminological debate (), so I’d like to propose we revisit one of the strangest items of WebKit-specific terminology: the phrase ‘roll out’.

In our industry, the typical meaning of the phrase ‘roll out’ is, of course, ‘deploy’ or ‘launch’; this corresponds with the colloquial usage of ‘roll out’ to mean ‘depart (for a destination)’. In WebKit, we use ‘roll out’ to mean the exact opposite, ‘revert’ or ‘roll back’.

I think the ship has sailed on this one. People who have been working on the WebKit project for long enough are so used to the phrase "rollout a patch" that it's gonna be tricky to change the terminology. Having said that, I'd much prefer the term "revert" over "rollout" or "rollback". It's also the term git uses.

This term is confusing enough for native English speakers outside our community, let alone non-natives (since phrasal verbs are notoriously tricky as it is).

As a non-native speaker myself, I never find this term confusing because I have no mental model of what "rollout" or "rollback" means. However, I find those two terms infinitely more confusing than the very direct "revert".

  • R. Niwa
# Kirsling, Ross (13 hours ago)

I'd be thrilled for us to use 'revert'. Somehow I'd convinced myself that it'd be easier to ask for this if we kept the 'roll' part, but I'm not really sure why I thought so.

Of course, it's fine for folks to continue to say 'roll out' due to habit; I just think it would be great if our automated 'rollouts' turned into automated 'reverts' instead.

Ross

On 3/6/20, 6:31 PM, "Ryosuke Niwa" <rniwa at webkit.org> wrote:

On Fri, Mar 6, 2020 at 6:15 PM Kirsling, Ross <Ross.Kirsling at sony.com> wrote:
>
> Late on Friday seems like a good time for a terminological debate (), so I’d like to propose we revisit one of the strangest items of WebKit-specific terminology: the phrase ‘roll out’.
>
> In our industry, the typical meaning of the phrase ‘roll out’ is, of course, ‘deploy’ or ‘launch’; this corresponds with the colloquial usage of ‘roll out’ to mean ‘depart (for a destination)’. In WebKit, we use ‘roll out’ to mean the exact opposite, ‘revert’ or ‘roll back’.

I think the ship has sailed on this one. People who have been working
on the WebKit project for long enough are so used to the phrase
"rollout a patch" that it's gonna be tricky to change the terminology.
Having said that, I'd much prefer the term "revert" over "rollout" or
"rollback". It's also the term git uses.

> This term is confusing enough for native English speakers outside our community, let alone non-natives (since phrasal verbs are notoriously tricky as it is).

As a non-native speaker myself, I never find this term confusing
because I have no mental model of what "rollout" or "rollback" means.
However, I find those two terms infinitely more confusing than the
very direct "revert".

- R. Niwa
# Maciej Stachowiak (13 hours ago)

I agree this usage of “roll out” is potentially confusing.

I think people say “roll out” for the symmetry to “check in”. It also creates the convenient term “roll back in” for when a rollout is undone.

Personally, I think we should say “revert” and avoid use of roll-phrases entirely. “unrevert” isn’t quite as natural as “roll back in”, but it’s good enough. Or you could say “re-land”.

# Konstantin Tokarev (13 hours ago)

07.03.2020, 05:41, "Kirsling, Ross" <ross.kirsling at sony.com>:

I'd be thrilled for us to use 'revert'. Somehow I'd convinced myself that it'd be easier to ask for this if we kept the 'roll' part, but I'm not really sure why I thought so.

On the negative side, it won't be possible anymore to say that someone is on a roll when they revert several patches in a row :)

# Alexey Proskuryakov (12 hours ago)

6 марта 2020 г., в 18:29, Ryosuke Niwa <rniwa at webkit.org> написал(а):

On Fri, Mar 6, 2020 at 6:15 PM Kirsling, Ross <Ross.Kirsling at sony.com> wrote:

Late on Friday seems like a good time for a terminological debate (), so I’d like to propose we revisit one of the strangest items of WebKit-specific terminology: the phrase ‘roll out’.

In our industry, the typical meaning of the phrase ‘roll out’ is, of course, ‘deploy’ or ‘launch’; this corresponds with the colloquial usage of ‘roll out’ to mean ‘depart (for a destination)’. In WebKit, we use ‘roll out’ to mean the exact opposite, ‘revert’ or ‘roll back’.

I think the ship has sailed on this one. People who have been working on the WebKit project for long enough are so used to the phrase "rollout a patch" that it's gonna be tricky to change the terminology. Having said that, I'd much prefer the term "revert" over "rollout" or "rollback".

I've been using "roll back" lately, but "revert" seems perfectly fine.

Want more features?

Request early access to our private beta of readable email premium.